Asc

Use:

Returns the ASCII value of a character value.

<Result> = Asc (<Character>)

Parameter details:

<Result> :
Numeric
ASCII value of a character value.

<Previous Name>:
String
Character value.

Example:

CodeASCII = Asc ("A") // CodeASCII = 65


In String Count

Use:

Counts the amount of ocurrencies of a substring in a string.

<Result> = In String Count (<String>,<String to Search>)

Parameter details:

<Result> :
Numeric
Number of ocurrencies of a substring in a string.

<String> :
String
Character string where the research will be performed.

<String to Search> :
String
Substring to search for.

Example:

Res = In String Count ("WireLessDesigner", "e") // Res = 4


Character

Use:

Returns the character that matches the numeric value according to the ASCII table.

<Result> = Character (<Value>)

Parameter details:

<Result> :
String
Character according to the ASCII table.

<Value> :
Numeric
Numeric value to search for on the ASCII table.

Example:

CaractASCII = Character (49) // CaractASCII = "1"


Complete

Use:

Sets the string length according to the specified value by adding spaces or cutting the original string.

<Result> = Complete (<String>,<Length>)

Parameter details:

<Result> :
String
String with the specified length.

<String> :
String
String to be affected.

<Length> :
Numeric
String length.
If the string chain is shorter than the specified length, spaces will be added. If the string chain is longer, it will be cut.

Example:

Res = Complete ("Alan", 8) // Res = "Alan "
Res = Complete ("Alexander", 4) // Res = "Alex"


Concatenate

Use:

Concatenates two strings.

<Result> = Concatenate (<String 1>,<String 2>)

Parameter details:

<Result> :
String
String that contains <String 1> and <String 2>.

<String 1> :
String
String to be concatenated.

<String 2> :
String
String to be concatenated.

Example:

Res = Concatenate ("Alain", " Delon") // Res = "Alain Delon"


Date/Time Constant

Use:

Creates a Date/Time constant.

<Result> = Date Heure (<Date or Time>)

Parameter details:

<Result> :
Date or Time
Date/Time constant.

<Date or Time>:
Date or Time
Date or Time.
(dd/mm/yyyy or dd-mm-yyyy or yyyymmdd) (YYYY: year, MM: month, DD: day)

Example:

Res = Date/Time({System.Date}) // Res = 12/01/2007
Res = Date/Time({System.Time}) // Res = 16:25:58


Numeric Constant

Use:

Creates a numeric constant.

<Result> = Numeric Constant (<Integer>)

Parameter details:

<Result> :
Numeric
Numeric constant.

<Integer> :
Numeric
Number to set as constant.

Example:

Res = Numeric Constant ( 0 ) // Res = 0


Text Constant

Use:

Creates an alpha-numeric constant.

<Result> = Text Constant (<String>)

Parameter details:

<Result> :
String
Alpha-numeric constant.

<String> :
String
String to set as constant.

Example:

Res = Text Constant ( "text" ) // Res = text


Sum

Use:

Adds two numeric values.

<Result> = Sum(<Value 1>,<Value 2>)

Parameter details:

<Result> :
Numeric
Adds two numeric values.

<Value 1> :
Numeric
Numeric value to add.

<Value 2> :
Numeric
Numeric value to add.

Example:

Res = Sum ( 10, 5 ) // Res = 15


String Replace

Use:

Replaces every ocurrence of a word for a new one.

<Result> = String Replace (<Initial String>,<String to Replace>,<New String>)

Parameter details:

<Result> :
String
String in which the replacements where already made.

<Initial String> :
String
Text where the replacements will be made.

<String to Replace> :
String
String to be replaced.

<New String> :
String
New string.

Example:

Res = String replace(Hello everybody|Hello|Bye) // Res = Bye everybody


Date Difference

Use:

Returns the difference (in days) between two dates.

<Result> = Date Difference (<Start Date>,<End Date>)

Parameter details:

<Result>:
Numeric
Difference (in days) between <Start Date> and <End Date>.

<Start Date>:
Date / Heure
First date (in DD/MM/YYYY format).

<End Date>:
Date / Heure
Final date (in DD/MM/YYYY format).

Example:

Res = Date Difference ({System.Time}|15:25:25) // Res = "04:48"


Date Format

Use:

Modifies the date format.

<Result> = Date Format (<Date to Format>)

Parameter details:

<Result>:
String or Date/Hour
Date with modified format.

<Date to Format>:
String or Date/Hour
Date whose format will be modified (dd/mm/yyyy or dd-mm-yyyy or yyyymmdd) (YYYY: year, MM: month, DD: day)

<Date Format>:
String
Format (YYYY: year, MM: month, DD: day)

Example:

Res = Date Format({System.Date}," YYMMDD") // Res = "070104"
Res = Date Format(22/02/2007," MMDDYYYY") // Res = "02222007"


Date System

Use:

Returns the system's date.

<Result> = Date System

Parameter details:

<Result> :
Date / Heure
System's date.

Example:

Res = Date System () // Res = "20070104"


Date Valide

Use:

Validates a date.

<Result> = Date Valide (<String>)

Parameter details:

<Result> :
Numeric
If the date is valid, the formula returns the text defined on TRUE key on Boolean Value section. If not valid, it returns the text defined on FALSE.

<String> :
String or Date/Hour
Date or string to validate (in DD/MM/YYYY format).

Example:

Res = Valide Date(20061201) // Res = OK
Res = Valide Date(20) // Res = ERROR (see Boolean Value)


Date by Day

Use:

Returns the day of the week which corresponds to the specified date.

<Result> = Date by Day (<Date>)

Parameter details:

<Result> :
String
Day of the week.

<Date> :
Date / Heure
Date to find out the day of the week (in DD/MM/YYYY format).

Example:

Res = Date by Day (15/01/2007) // Res = Monday


Date by Month

Use:

Returns the month which corresponds to the specified date.

<Result> = Date by Month (<Date>)

Parameter details:

<Result> :
String
Month which corresponds to the specified date.

<Date> :
Date / Heure
Date to find out the month (in DD/MM/YYYY format)

Example:

Res = Date by Month (15/01/2007) // Res = January


Date Sum

Use:

Increases a date in days.

<Result> = Date Sum (<Date>,<Integer>)

Parameter details:

<Result> :
Date / Hour
Date with N days increased.

<Date> :
Date / Hour
Date to add days to (in DD/MM/YYYY format).

<Integer> :
Numeric
Amount of days to increase.

Example:

Res = Date Sum (15/01/2007|30) // Res = 14/02/2007


Date Sustract

Use:

Decrements a date a specific number of days.

<Result> = Date Sustract (<Date>,<Integer>)

Parameter details:

<Result> :
Date
Date with removed days.

<Date> :
Date
Date to remove days to (in DD/MM/YYYY format).

<Integer> :
Whole number
Amount of days to remove.

Example:

Res = Date Sustract (14/02/2007|30) // Res = 15/01/2007


Date to Integer

Use:

Converts a date (DD/MM/YYYY) into integer. Returns the number of days since 01/01/1800.

<Result> = Date to Integer (<Date>)

Parameter details:

<Result> :
Numeric
Amount of days from the 01/01/1800 to <Date>.

<Date> :
Date / Heure
Date (in DD/MM/YYYY format).

Example:

Res = Date to Integer (15/01/2007) // Res = 75620


Division

Use:

Calculates the division between two values.

<Result> = Division (<Value 1>,<Value 2>)

Parameter details:

<Result> :
Numeric
Division of the first number by the second.

<Value 1> :
Numeric
Dividend.

<Value 2> :
Numeric
Divider.

Example:

Res = Division (15|2) // Res = 7.5
Res = Division (10|2) // Res = 5


Right

Use:

Extracts N characters from the right side of the string.

<Result> = Right (<String>,<Length>)

Parameter details:

<Result> :
String
Right side of the string.

<String> :
String
String from which N characters will be extracted.

<Length> :
Numeric
Length to extract from the right side of the string.

Example:

Res = Right (WireLessDesigner|8) // Res = Designer


INI Writing

Use:

Writes a specific value in an INI file (or structured like a .INI file)

<Result> = INI Writing (<Section>,<Key Word>,<Value>,<Ini File>)

Parameter details:

<Result> :
String
If the operation was carried out, the formula returns the text defined on TRUE key on Boolean Value section. Otherwise, the formula returns the text defined on FALSE.

<Section> :
String
Name of the section where the writing must be carried out. If this section does not exist, it will be automatically created.

<Key Word > :
String
Name of the key word on the section that will contain the information to be written. If this key word does not exist, it will be automatically created.

<Value> :
String
Text to be written on the key word of the specified section.

<Ini File> :
String
Complete file name (with its extension).

Example:

Res = INI Writing (DEBUG|LEVEL|99|c:\designer.ini) // Res = OK (see Boolean Value)


Integer to Date

Use:

Converts an integer to date format. This integer corresponds to the number of days since 1/01/1800.

<Result> = Integer to Date (<Value 1>)

Parameter details:

<Result> :
Date / Hour
Date that corresponds to <Value 1> days since 01/01/1800.

<Value 1> :
Integer
Number of days since 01/01/1800.

Example:

Res = IntegertoDate (75620) // Res = 15/01/2007


String Extract

Use:

Extracts a substring from a specified string according to an index and a separator.

<Result> = String Extract (<String>,<Index>,<Splitting Character>)

Parameter details:

<Result> :
String
Substring extracted from <String>. This substring goes from <Index> - 1 splitting character to <Index> splitting character.

<String> :
String
String which contains the substring to be extracted.

<Index > :
Numeric
Splitting character sequence number.

<Splitting Character> :
String
String to delimit the substrings. This string is not included on the result.

Example:

Countries= "France, Italie, Germany, Spain"
StringExtract (Countries, 1, ", ") // Res = "France"
StringExtract (Countries, 2, ", ") // Res = "Italie"
StringExtract (Countries, 3, ", ") // Res = "Germany"
StringExtract (Countries, 4, ", ") // Res = "Spain"
StringExtract (Countries, 5, ", ") // Res = #PAR1


File Load

Use:

Returns the content of a file on a variable.

<Result> = File Load (<File to Load>)

Parameter details:

<Result> :
String
File content.

<File Name> :
String
Full file name.

Example:

Res = File Load (c:\designer.txt) // Res = file load test


File Binary Search

Use:

Binary search on a fixed-lenght text file.

A fixed-lenght text file is composed of a group of records of the same size, in other words, which contain the same number of characters. Records are limited by CR (carriage return, 0x0D) and LF (line feed, 0x0A) characters.

<Result> = File Binary Search (<File Name> ,<Search Key>,<Start Position>, <Record Size>)

Parameter details:

<Result> :
Numeric
File position where the key was found. Starts at 0 (zero). Returns -1 if the search fails.

<File Name> :
String
Full name of the file where the search will be performed.

<Search Key>:
String
Text to search for.

<Start Position>:
Numeric
Start position. Starts at 0 (zero).

<Record Size>:
Numeric
Lenght of the record to search for. The record lenght must include the carriage return (CR/LF).

Example:

Res = File Binary Search (X:\winnt\designer.ini|EXE|1|15) // Res = 0


File Sequential Search

Use:

Sequential search on a fixed-lenght text file.

A fixed-lenght text file is composed of a group of records of the same size, in other words, which contain the same number of characters. Records are limited by CR (carriage return, 0x0D) and LF (line feed, 0x0A) characters.

<Result> = File Sequential Search (<File Name> ,<Search Key>,<Start Position>, <Record Size>)

Parameter details:

<Result> :
Numeric
File position where the key was found. Starts at 0 (zero). Returns -1 if the search fails.

<File Name> :
String
Full name of the file where the search will be performed.

<Search Key>:
String
Text to search for.

<Start Position>:
Numeric
Start position. Starts at 0 (zero).

<Record Size>:
Numeric
Lenght of the record to search for. The record lenght must include the carriage return (CR/LF).

Example:

Res = File Sequential Search(X:\winnt\designer.ini|EXE|1|15) // Res = 0


File Copy

Use:

Copies one or more files.

<Result> = File Copy (<File Source> ,<File Destination>)

Parameter details:

<Result> :
String
If the copy is successfull, the formula returns the text defined on TRUE key on Boolean Value section. Otherwise, the formula returns the text defined on FALSE.

<File Source> :
String
Full name of the file to be copied. Jocker caracters (*, ?) are allowed.

<File Destination>:
String
Full name of the destination file.

Example:

Res = File Copy (C:\*.txt|c:\TEST) // Res = OK (see Boolean Value)


File Write

Use:

Writes on a fixed-length text or binary file.

A "fixed-lenght text or binary file" is composed of a group of records of the same size, in other words, which contain the same number of characters.
Records can be limited by CR (carriage return, 0x0D) and LF (line feed, 0x0A) characters, so that every record be a text line.

<Result> = File Write (<File> ,<Record Size>,<Line/Row>, <Value>,<Start Position>)

Parameter details:

<Result> :
String
If writing is successfull, the formula returns the text defined on TRUE key on Boolean Value section. Otherwise, the formula returns the text defined on FALSE.

<File> :
String
Full file name.

<Record Size>:
Numeric
Record lenght. The record lenght must include CR (carriage return, 0x0D) and LF (line feed, 0x0A) characters.

<Line/Row>:
Numeric
Line or row to be written. Start at 1 (one).
* If this record number exists, it will be totally or partially modified (overwritten).
* If this record number doesn't exist, it will be created having the content of <Value>.
* If one or many intermediary records are missing onthe file, they will be created having null content (binary 0x00).

<Value>:
String
Value to write or overwrite. If this string lenght is shorter than the record lenght, remaining charcters will not be modified.

<Start Position>:
Numeric
Start position on the record for writing. Start at 0 (zero).

Example:

Res = File Write(C:\test.txt|20|1|this is a test|1) // Res = OK (see Boolean Value)


File Exists

Use:

This formula verifies if a file is present on the PC.

<Result> = File Exists (<File>)

Parameter details:

<Result> :
String
If the file exists, the formula returns the text defined on TRUE key on Boolean Value section. Otherwise, the formula returns the text defined on FALSE.

<File> :
String
Full file name.

Example:

Res = File Exists(C:\test.txt) // Res = ERROR (see Boolean Value)


File Read

Use:

Reads form a fixed-lenght text file.

A "fixed-lenght text or binary file" is composed of a group of records of the same size, in other words, which contain the same number of characters.
Records can be limited by CR (carriage return, 0x0D) and LF (line feed, 0x0A) characters, so that every record be a text line.

<Result> = File Read (<File>,<Record Size>,<Line/Row>)

Parameter details:

<Result>:
String
The line/record content. If the line/record doesn't exist (if the line number is superior to the number of records on the file), the result is an empty string.

<File>:
String
Name of the file to be read.

<Record Size>:
Numeric
Record size. The line/record size must include the CR (carriage return, 0x0D) and LF (line feed, 0x0A) characters.

<Line/Row>:
Numeric
Line to be read. Start at 1 (one).

Example:

Res = File read(C:\test.txt|20|2) // Res = "this is a test "


File Rename

Use:

Renames a file.

<Result> = File Rename (<Previous Name>,<New Name>)

Parameter details:

<Result> :
String
If modification is successfull, the formula returns the text defined on TRUE key on Boolean Value section. Otherwise, the formula returns the text defined on FALSE.

<Previous Name>:
String
Previous file name.

<New Name> :
String
New file name.

Example:

Res = File Rename(C:\prueba.txt|c:\test.txt) // Res =OK (see Boolean Value)


File Save

Use:

Creates a file from a variable.

<Result> = File Save (<File to Save>,<File Content>)

Parameter details:

<Result>:
String
If the file is created, the formula returns the text defined on TRUE key on Boolean Value section. Otherwise, the formula returns the text defined on FALSE.

<File to Save>:
String
Full name of the file to be created.

<File Content>:
String
Content of the file to be created.

Example:

Res = FileSave(C:\test.txt|test) // Res =OK (see Boolean Value)


File Delete

Use:

Deletes a file.

<Result> = File Delete (<File>)

Parameter details:

<Result> :
String
If the file is deleted, the formula returns the text defined on TRUE key on Boolean Value section. Otherwise, the formula returns the text defined on FALSE.

<File Name> :
String
Full name of the file to be deleted.

Example:

Res = File Delete(C:\test.txt) // Res = ERROR (see Boolean Value)


Left

Use:

Extracts N characters from the left side of the string.

<Result> = Left (<String>,<Length>)

Parameter details:

<Result> :
String
String extracted from the left side of <String>.

<String> :
String
Initial string. This string will not be modified.

<Length> :
Numeric
Number of characters to extract.

Example:

Res = Left ( "Easy developpement", 4) // Res = "Easy"


Random

Use:

Returns a random number between the two specified numbers.

<Result> = Random (<Value 1>,<Value 2>)

Parameter details:

<Result>:
Numeric
Random number between <Value 1> and <Value 2>.

<Value 1> :
Numeric
Minimum value.

<Value 2> :
Numeric
Maximum value.

Example:

Res = Random(6|90) // Res = "33"


Time Sum

Use:

Adds the time values set as parameters.

<Result> = Time Sum (<Time1>,<Time 2>)

Parameter details:

<Result>:
Date / Time
Additon of <Time 1> and <Time 2>.

<Time 1>:
Date / Time
Time value to be added. Format:
HHMMSShh
HHMMSS
HHMM
HH

<Time 2>:
Date / Time
Time value to be added. Format:
HHMMSShh
HHMMSS
HHMM
HH

Example:

Res = Time Sum ({System.Time}|10:10) // Res = "21:03"


Time Difference

Use:

Returns the difference (in hours) between two times.

<Result> = Time Difference (<Start Time>,<End Time>)

Parameter details:

<Result>:
Date / Time
Difference between <Start Time> and <End Time>.

<Start Time>:
Date / Time
Initial time in format:
HHMMSShh
HHMMSS
HHMM
HH

<End Time>:
Date / Time
Final time in format:
HHMMSShh
HHMMSS
HHMM
HH

Example:

Res = Time Difference ({System.Time}|15:25:25) // Res = "04:48"


Time Format

Use:

Modifies the time format.

<Result> = Time Format (<Time to Format>,<Number of digits>)

Parameter details:

<Result>:
String
String with the specified format.

<Time to Format>:
String
Time in HHMMSShh format (HH: hours, MM: minutes, SS: seconds and hundreths of seconds).

<Number of digits>:
Numeric
Number of digits to keep from the time format.

Example:

Res = TimeFormat ({System.Time}|4) // Res = "1216"
Res = TimeFormat ({System.Time}|6) // Res = "121658"


Time System

Use:

Returns the system's time.

<Result> = Time System ( )

Parameter details:

<Result>:
Date / Time
Current time

Example:

Res = Time System() // Res = "15332105"


Time Validate

Use:

Validates a time.

<Result> = Time Validate (<Time to Validate>)

Parameter details:

<Result>:
String or Date/Time
If time is valid, or if "Time" parameter is an empty string, the formula returns the text defined on TRUE key on Boolean Value section. Otherwise, if time is not valid, the formula returns the text defined on FALSE.

A time is considered not valid when:
"HH" is not included between "00" and "23".
"MM" is not included between "00" and "59".
"SS" is not included between "00" and "59".
"hh" is not included between "00" and "99".

<Time to Validate>:
String or Date/Time with the format:
HHMMSShh
HHMMSS
HHMM
HH

Example:

Res = Time Validate("23122222") // Res = OK
Res = Time Validate("23:12") // Res = OK
Res = Time Validate("23") // Res = OK
Res = Time Validate("24") // Res = ERROR
Res = Time Validate("23137099") // Res = ERROR (see Boolean Value)


Time to Integer

Use:

Returns the number of seconds since 00:00:00.

<Result> = Time to Integer (<Time>)

Parameter details:

<Result> :
Numeric
Number of seconds from 00:00:00 to <Time>.

<Time> :
Date / Time
Hour to be converted, expressed with format HHMMSShh. If this parameter corresponds to a null string (""), the function returns 0 (zero).

Example:

Res = Time to Integer(11:05:03) // Res = 39903


Inverse

Use:

Returns the complement to 255 for each character of a string.

<Result> = Inverse (<String>)

Parameter details:

<Result> :
String
The character string reversed.

<String> :
String
String to be reversed. This string will not be modified.

Example:

Res = Inverso(TEST) // Res = «º¬«


INI Read

Use:

Reads the content of an INI file (or an INI-structured file).

<Result> = Long (<Section>,<Key Word>,<Ini File>)

Parameter details:

<Result> :
String
Content of an INI file (or an INI-structured file).

<Section> :
String
Name of the section where the reading must be carried out.

<Key Word > :
String
Name of the key word containing information to be read.

<Ini File> :
String
Complete file name (with its extension).

Example:

Res = INI Read(DEBUG|LEVEL|c:\designer.ini) // Res = 99


Upper Case

Use:

Changes a string to uppercase.

<Result> = Upper Case (<Section>)

Parameter details:

<Result> :
String
String in upercase.

<Section> :
String
String to be changed.

Example:

Res = Upper Case(hello) // Res = HELLO


Middle

Use:

Extracts a substring from a specified string according to a start position and a length.

<Result> = Middle (<Section>,<Start Position>,<Length>)

Parameter details:

<Result> :
String
Substring extracted from <String>.

<String> :
String
String where from a fixed-length substring will be extracted. This string will not be modified.

<Start Position> :
Numeric
Position where the extraction will begin. If this parameter is null, the extraction will start on the begining of the string.

<Length> :
Numeric
Length of the substring to be extracted.

Example:

Res = Middle(Hello everybody|7|9) // Res = everybody


Lower Case

Use:

Changes a string to lowercase.

<Result> = Lower Case (<String>)

Parameter details:

<Result> :
String
String in lowercase.

<String> :
String
String to be affected.

Example:

Res = Low Case(HELLO) // Res = hello


Module

Use:

Returns the remainder of an integer division.

<Result> = Module (<Dividend>,<Divisor>)

Parameter details:

<Result> :
Numeric
Returns the remainder of an integer division.

<Dividend > :
Numeric
Dividend.

<Divisor> :
Numeric
Divisor.

Example:

Res = Module (10|3) // Res = 1


Module 10

Use:

Returns the module 10 of the specified string.

<Result> = Module 10 (<String to evaluate>)

Parameter details:

<Result>:
String
Module 10 of the specified string. This string will contain just one number.

<String to evaluate>:
String
String to evaluate. WARNING: this string must contain only numbers.

Example:

Res = Module 10(12345) // Res = 7


Multiplication

Use:

Multiplication of two values.

<Result> = Multiplication (<Value 1>,<Value 2>)

Parameter details:

<Result> :
Numeric
Result of the multiplication.

<Value 1> :
Numeric
Value to be multiplied.

<Value 2> :
Numeric
Value to multiply.

Example:

Res = Multiplication(10|3) // Res = 30


NULL

Use:

Assigns a null value to a variable.

<Variable> = Null

Parameter details:

<Variable> :
Null
Null value.

Example:

Res = Null


Week Number

Use:

Returns the week number for the specified date.

<Result> = Week Number (<Date>)

Parameter details:

<Result> :
Numeric
Week number that corresponds to the specified date.

<Date> :
Date / Hour
Date to calculate its week number.

Example:

Res = Week Number (16/01/2007) // Res = 3


Position

Use:

Returns the position where a string is contained in another.

<Result> = Position (<String to explore>,<Search String>,<Start Position>)

Parameter details:

<Result> :
Numeric
Start position where a string is contained in another. The application returns "0" if the string is not found.

<String to explore> :
String
String where the substring will be searched.

<Search String> :
String
String to be searched.

<Start Position> :
Numeric
Search start position.

Example:

Res = Position(position where a string is contained|string|5) // Res = 18


Repeat

Use:

Returns a string containing N times the original string.

<Result> = String Replace (<String>,<Amount>)

Parameter details:

<Result> :
String
String which contains N times the original string.

<String> :
String
String to repeat.

<Amount> :
Numeric
Number of times to repeat the string.

Example:

Res = Repeat (Hello|2) // Res = HelloHello


No Spaces

Use:

Returns the string without spaces at right or at left.

<Result> = No Spaces (<String>)

Parameter details:

<Result> :
String
Character string without spaces at right or at left.

<String> :
String
String to affect.

Example:

Res = NoSpaces ( 123 ) // Res = 123


SavColorLot

Use:

Returns the colour of a lot according to a date.

<Result> = SavColorLot (<Date>)

Parameter details:

<Result>:
String
Lot colour.

<Date>:
String
Date.


Set Terminal Langage

Use:

Configures or returns the device language.

<Result> = Set Terminal Langage (<String>)

Parameter details:

<Result>:
String
Number that corresponds to the device language (3: english, 5: french, 7: spanish).

<String>:
String
* Set language (3: english, 5: french, 7: spanish)
* or return langage ("0").

Example:

Res = SetTerminalLanguage (0) // Res = 3


Sustract

Use:

Subtracts the first number from the second.

<Result> = Sustract (<Value 1>,<Value 2>)

Parameter details:

<Result> :
Numeric
Result of the subtraction between two values.

<Value 1> :
Numeric
First number to affect.

<Value 2> :
Numeric
Number to subtract to <Value 1>.

Example:

Res = Sustract (10|3) // Res = 7


Long

Use:
Returns the string's length.

<Result> = Long (<String>)

Parameter details:

<Result> :
Numeric
String's length.

<String> :
String
String to be measured.

Example:

Res = Taille (Hello) // Res = 5


Directory Rename

Use:

Renames a directory.

<Result> = Directory Rename (<Previous Name>,<New Name>)

Parameter details:

<Result> :
String
If the directory is renamed, the formula returns the text defined on TRUE key on Boolean Value section. Otherwise, the formula returns the text defined on FALSE.

<Previous Name> :
String
Previous directory name.

<New Name> :
String
New directory name.

Example:

Res = Directory Rename (C:\prueba|c:\test) // Res = OK (see Boolean Value)


Val

Use:

Returns the numeric value of a string.

<Result> = Val (<String>)

Parameter details:

<Result> :
Numeric
Numeric value of a string.

<String> :
String
String to affect. This string must contain only numbers.

Example:

Res = Val (8) // Res = "8"


Number to String

Use:

Returns a numeric value formatted as a string.

<Result> = Number to String (<Value>)

Parameter details:

<Result> :
String
Numeric value formatted as a string.

<Value> :
Numeric
Numeric value to format.

Example:

Res = Number to String (8) // Res = "8"


Directory Exists

Use:

This formula verifies if a directory is present on the PC.

<Result> = Directory Exists (<Directory>)

Parameter details:

<Result> :
String
If the specified directory exists, the formula returns the text defined on TRUE key on Boolean Value section. Otherwise, the formula returns the text defined on FALSE.

<File> :
String
Full directory name.

Example:

Res = Directory Exists (C:\test) // Res = ERROR (see Boolean Value)


Directory Delete

Use:

Deletes a directory.

<Result> = Directory Delete (<Directory>)

Parameter details:

<Result> :
String
If the directory is deleted, the formula returns the text defined on TRUE key on Boolean Value section. Otherwise, the formula returns the text defined on FALSE.

<Directory Name> :
String
Full name of the directory to be deleted.

Example:

Res = Directory Delete (C:\test) // Res = ERROR (see Boolean Value)


Directory Make

Use:

Creates a directory.

<Result> = Directory Make (<Directory>)

Parameter details:

<Result> :
String
If the directory is created, the formula returns the text defined on TRUE key on Boolean Value section. Otherwise, the formula returns the text defined on FALSE.

<Directory Name> :
String
Full name of the directory to be created.

Example:

Res = Directory Make (C:\test) // Res = OK (see Boolean Value)


Boolean Value

Description:

It is possible to define the value to be returned by those formulas which return true/false values. In order to do that, go to BOOLEAN VALUE section on WireLessDesigner.ini file, which is located on $SystemRoot folder (usually X:\WINNT o X:\Windows).

Example:

Some possible values for true case are "1"/"TRUE"/"OK" etc. and "0"/"FALSE"/"ERROR" for false case. For example, if defined:
[BOOLEAN VALUE]
TRUE=OK
FALSE=ERREUR

The value to be returned will be "OK" for true and "ERREUR" for false on the following formulas: File Copy, File Write, File Exists, File Rename, File Save, File Delete, Date Valide, Time Validate, Directory Rename, Directory Exists, Directory Delete and INI Writing.

Default values:

If you dont define any value, the application will return by default:
-"VRAI" for true
-"FAUX" for false


Text to date

Use:

Converts text in a specific format into a date in YYYYMMDD format.

<Result> = Text to Date (<Format>,<Text>)

Parameter details:

<Result> :
Date / Hour
Date field in YYYYMMDD format.

<Format> :
Text
Text format.

Possible values for the format:

CC / cc: Century - if not specified, the current is used.

Y / YY / YYYY / A / AA / AAAA / y / yy / yyyy / a / aa / aaaa: Year - if not specified, the current is used.

M / MM / m / mm: Month - if not specified, the current is used.

D / DD / d / dd / J / JJ / j / jj: Day - if not specified, the current is used.

NNN: Number of day of the year.

All character different from those detailed before is ignored.

<Text> :
Text
Text to format, having the same length as the Format.

Example:

Res = Text to Date (dd***m//yy,12***2//09) // Res = 12022009


Text to hour

Use:

Converts text in a specific format into an hour in HHMMSS format.

<Result> = Text to hour (<Format>,<Text>)

Parameter details:

<Result> :
Date / Hour
Date field in HHMMSS format.

<Format> :
Text
Text format.

Possible values for the format:

H / HH / h / hh: Hour - if not specified, the current is used.

M / MM / m / mm: Minutes - if not specified, the current is used.

S / SS / s / ss: Seconds - if not specified, the current is used.

All character different from those detailed before is ignored.

<Text> :
Text
Text to format, having the same length as the Format.

Example:

Res = Date to Hour (h!!m//s(,2!!2//9() // Res = 020209